NWSTP Forum
Username:
Password:
Save Password


Register
Forgot Password?
  Home   Forums   Events Calendar   NWSTP Admins   Guestbook   FAQ   RSS   Register
Active Topics | Active Polls | Resources | Members |   | Live Chat | Avatar Legend | Search | Statistics
[ Active Members: 0 | Anonymous Members: 0 | Guests: 4 ]  [ Total: 4 ]  [ Newest Member: Boobbikst ]
 All Forums
 NWSTP
 Sy/Ty Help
 help! antifreeze leak
 New Topic |   Reply to Topic |   Printer Friendly
Author Previous Topic: ABS Issue? Topic Next Topic: 93 TY running like doo doo  

saxo4450
Starting Member

Posted - August 23 2007 :  8:36:40 PM  Show Profile  Reply with Quote
I just noticed today that my passenger floor was soaked wet with antifreeze. I noticed a strong rubberish smell inside the vehicle before I found the mess on the floor. The engine coolant container under the hood is empty.
I don't understand what's going on. Anyone else had this problem? can anyone shed some light on the situation?

Country: Canada | Posts: 1

Ty0279
New Member



Posted - August 24 2007 :  11:17:41 AM  Show Profile  Reply with Quote
Your heater core has a leak in it. You can replace it or block it off (you won't have heat if you do that).

Here is a "how to"...
http://www.sytyarchives.com/howto/viewarticle.php?article_name=heater_core.php&dir=climate_controls



Kurt
'92 Ty #279
Kirkland, WA

Country: USA | Posts: 69 Go to Top of Page

GMCTurbo
Starting Member



Posted - September 18 2007 :  08:53:45 AM  Show Profile  Reply with Quote
Any idea of the average number of hours you guys have spent doing this? I need to do mine... just debating whether I'd rather bypass it (winter coming up and all :-) ) or do the dirty work.

Peter W.
'93 Ty - black

Country: USA | Posts: 37 Go to Top of Page

Paul
Site Admin



Posted - September 20 2007 :  4:48:21 PM  Show Profile  Visit Paul's Homepage  Send Paul an AOL message  Send Paul an ICQ Message  Click to see Paul's MSN Messenger address  Reply with Quote
Looks like it would take a couple of hours. Without those instructions on the archives it would take forever.

I had the dash out and should have done it then but it is doable with it in there. Just a PITA.


Paul Schwab
93 Black/Black Typhoon #424
NWSTP Site Admin
Kirkland, WA

Country: USA | Posts: 506 Go to Top of Page
  Previous Topic: ABS Issue? Topic Next Topic: 93 TY running like doo doo  
 New Topic |   Reply to Topic |   Printer Friendly
Jump To:
NWSTP Forum © 1998-2011 NWSTP Go To Top Of Page
This page spooled up in 0.19 seconds Syclone and Typhoon By GMC Powered By: Snitz Forums 2000 Version 3.4.03
   

 


This Ring Site is owned by Sportmachines. Want to join the Ring?
[
Skip Prev] [Prev] [Next] [Skip Next] [Random] [Next 5] [List Sites
]